Servers@GeorgeLiu.me

Did you ever get this code while using FreeFileSync: “Windows Error Code 1314: A required privilege is not held by the client.“?

I did. Many times. I thought it was a Linux file permission error on my Raspberry Pi 3 OMV setup, and I chmodded and chowned an unbelievable amount of times, to no effect. And then, while setting up a new temporary NAS on a Raspberry Pi 3, I found a new page: “Windows Error Code 1314: A required privilege is not held by the client.

If you don't really need to copy file system permissions, 
turn them off in global settings.

I solved the problem!

Security@Georgeliu.me

CrashPlan is a great data backup service. It has some drawbacks, such as high memory use and slow speeds (being based on Java), but it has some terrific benefits as well. It is about the only program that allows you to store data on multiple computers and on the computers of friends, a free option.

However, I recently ran into a problem with CrashPlan: something was causing CrashPlan to see the folder as 0 bytes instead of several gigabytes. It could not see the data in the folders, and as a result, no data was being backed up.

So what went wrong? I initially thought it was something to do with security settings and file permissions. I searched Google for a while and came up with some hints, such as taking ownership of files and such. For that task, using Ultimate Windows Tweaker allowed me to easily add the correct registry extension to the right-click context menu and take ownership of all files.

That didn’t fix anything. I was still pretty sure it was a file permission error, so I looked at the base drive, and made sure all accounts (Myself and Everyone) had the necessary permissions, with the correct option selected (applying these permissions to “this folder, subfolders, and files”).

It still didn’t work, so I played around in CrashPlan to see what was going on. Only some folders were not capable of being backed up. And as it turns out, the only folders that CrashPlan could not access were the ones being shared with the Windows 7 HomeGroup. Here was a big hint, and I eventually followed these steps:

  1. Disable “Password protected sharing” (Control Panel>All Control Panel Items>Network and Sharing Center>Advanced Sharing Settings\Password protected sharing)
  2. Add “Everyone” account to necessary folders and give them “full control” permissions (Right-click folder, Security\Advanced\Change Permissions\Add\Allow Full Control)

I am not sure that step 1 is necessary, but I believe that because security was enabled, Windows cut down access from Myself and Everyone to just Myself and HomeUsers (HomeGroup). Either way, the most important thing is this: CrashPlan needs to have an Everyone account associated with the folders to back up (and the necessary permissions to read the folder). Otherwise, backups may not work.

But funnily enough, another shared folder that is backed up in CrashPlan has Myself, Administrators, HomeUsers, and SYSTEM user accounts attached to it. Maybe SYSTEM is enough?

 


Comments

Previous comments imported from a different version of this blog.

Hint: use System instead of Everyone for security reasons.

I had this same problem and solved it. I moved an external hard drive from a Win XP to a new pc with Win 7 and found Crashplan saw nothing under a directory with 300 gig. Yet other folders on the same drive did not have the problem. That directory with 300 gig has been shared previously. I found I had to add SYSTEM to the permission so that Crashplan could see the entire directory structure underneath it. After more digging, adding Everyone will have the same effect. — CharlieI didn’t have to give everyone FULL permission, just read permission. But the trick was to disable the Password Protected Sharing. THANK YOU!…saved me a lot of grief! — Steve

I found success by adding SYSTEM account. Not full control and with password protected sharing turned ON. — Sean

It was option 1 for me – the password sharing. Disabled it and crashplan immediately worked again. No idea why this happened or what caused it though. — Nicholas

I had the same problem on Windows Server 2012. CrashPlanPRO wasn’t backing up shares I had changed the security settings on. Adding the SYSTEM user and giving it read and execute rights did the trick. Thanks — Josh