SimpleTech SimpleShare NAS

Troubleshooting the SimpleTech SimpleShare NAS? Here are some tips.

Last week, I bought a SimpleTech SimpleShare 250GB NAS (Network Attached Storage) drive off of Newegg. It comes with a handy print server, RAID capability, multiple USB HD capability, and all sorts of handy things. Now that it is running, it is actually pretty cool. It’s a useful device that comes with a free software backup utility. Windows XP also comes with one, but I figured I’d use this one instead.

There are, however, a glaring problem with the drive: the setup process. For most people, it should be ok, but forums all over the web report problems mapping the drive to a drive letter. How do you fix it? It’s pretty easy when you know what to do:

The first thing to check after discovering Error 53 is to disable the integrated print server. You can enable it later after mapping the drives, but don’t use it right now. You can access the menu for this in the advanced portion of the setup.

If that doesn’t work, it might be the firmware. Version 1.09 is not as feature rich as 1.07, but upgrading the firmware might solve the problem. This “new” firmware removes RAID functionality, user controls, domain controller, and some other things, but it just might fix the biggest problem. It also allows your drive to spin down when not in use, something 1.07 has problems with. You can find this firmware at SimpleTech but be aware that it is probably just a stopgap measure since 1.07 is the official version.

As I said, now that it is working, it is a pretty cool device. It runs fairly cool for an external drive and has a lot of functionality built in. It’s great for backups, has a print server, and, if the setup works the first time, it’s not too difficult to use. And if the setup doesn’t work, that is what this post is for.

SimpleTech SimpleShare NAS
Scroll to top